Access Keys:
Skip to content (Access Key - 0)


VSA Compatibility and Prerequisites

Print this page

VSA Compatibility

Platform compatibility VSA 2.0.1 supports the following platforms
OS Version Architecture
Windows Windows XP, Windows Vista, Windows 7 x86, 32-bit, 64-bit
Ubuntu 11.04 or later x86, 32-bit, 64-bit
OSX 10.4 (Tiger) or later x86, 32-bit, 64-bit

For Linux installations please ensure your OS and hardware use the same architecture (for example, a 32-bit OS with a 32-bit processor).

Java compatibility VSA 2.0.1 requires a Java Development Kit (JDK) 1.6. Installation of the Java Runtime Environment (JRE) is NOT sufficient for proper functioning of VSA.

If you are running a 64-bit processor architecture, make sure you properly install and set up the 64-bit version of your Java virtual machine (JVM).

If installing the Eclipse Plugin, you can check the version of Java from within Eclipse as follows:
Select Help ► About Eclipse Platform (or About Eclipse SDK, depending on your installation) ► Installation Details.

Compatibility with previous versions of VSA VSA 2.0.1 is compatible with projects created using VSA 1.x.

When opening projects created with older versions, VSA 2.0.1 will automatically migrate them to the new VSA 2.x data structure.

Note that it will no longer be possible to open these migrated projects using older versions of VSA.

Compatibility with other OpenCloud products VSA 2.0.1 is compatible with the following OpenCloud products:
Product Version
Rhino TAS Rhino 2.3.x or greater
CGIN Connectivity Pack CGIN 1.3.x or greater (including CGIN 1.5.x)

Prerequisites for VSA as a Standalone Application

JavaHL The VSA Standalone Application requires Subclipse JavaHL 1.7.

JavaHL is a prerequisite for Subclipse, which provides Subversion support within Eclipse. See the Subclipse Java HL wiki page for more information. JavaHL is required even if you do not plan to use Subversion.

The installation instructions under "How do I get JavaHL?" on the Subclipse Java HL wiki page do not define which version of JavaHL you wish to install. Following the instructions may result in an installation of JavaHL 1.6, which is not supported by VSA 2.x.

Distributions with JavaHL 1.7 include userSVN from WANDisco and Subversion Edge from CollabNet (and others).

Prerequisites for VSA as an Eclipse Plugin

Eclipse compatibility for the VSA Plugin The VSA 2.0.1 Eclipse Plugin is compatible with the following versions of Eclipse:
Eclipse Version
Eclipse 3.6 (Helios)
Eclipse 3.7 (Indigo)
Eclipse 4.2 (Juno)
Adaptavist Theme Builder Powered by Atlassian Confluence