JSLEE Discussions
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
Invalid usage for command 'getsecuritypolicy'
Forum Index » Rhino SLEE Discussions
Author Message
inovar_test


Joined: 12/08/2017 08:20:01
Messages: 20
Offline

How can I list the current security policy for the deployed sbbs? I've tried the following but it results in an error:

[1 alarm] [admin@localhost (#28)] listsbbs
SbbID[name=CGIN Examples Relay Sbb,vendor=OpenCloud,version=1.5.2]
SbbID[name=CGIN Examples Simple Sbb,vendor=OpenCloud,version=1.5.2]

[1 alarm] [admin@localhost (#1)] getsecuritypolicy SbbID[name=CGIN Examples Simple Sbb,vendor=OpenCloud,version=1.5.2]
Invalid usage for command 'getsecuritypolicy'. Usage:
getsecuritypolicy (<ComponentID> | <LibraryID> [jarname]) [true|false]
Returns the security policy associated with the specified ComponentID. The
optional 'jarname' argument can be used to specify a nested library jar for
LibraryIDs. The original policy will be returned if the final argument is
'true'.



stevena


Joined: 27/03/2008 13:43:16
Messages: 274
Location: Cambridge, UK
Offline

Try putting double quotes around the component ID. The space in the middle of the component name will be causing the parser to read too many tokens.

Steven Adams
Senior Software Engineer
OpenCloud
 
Forum Index » Rhino SLEE Discussions
Go to:   
Powered by JForum 2.1.8 © JForum Team